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An Error Occurred While Enumerating Folders

Overview

The GFI MailEssentials Bayesian Analysis Wizard is a tool that can be used to update the Bayesian database with information from your spam and legitimate email. The wizard improves the ham/spam information in the Bayesian database by retrieving this information from existing emails located in an Exchange mailbox or in an Outlook PST file rather than waiting for it to learn from outbound mail. This will make the Bayesian filter more effective sooner.

This article describes a solution to an error that is encountered when the Bayesian Wizard is unable to scan the Email location which can be an Exchange mailbox or Outlook PST file.

Diagnosis

When using the Bayesian Wizard to retrieve information from either a Microsoft Outlook Profile (PST file) or from a Microsoft Exchange mailbox, the following error occurs:

 An error occurred while enumerating folders 

 

Prerequisites

Environment

  • GFI MailEssentials
  • Microsoft Outlook on Windows 10 or later
  • Microsoft Exchange 2010/2013/2016/2019
The Bayesian Analysis Wizard requires Microsoft Outlook running on Windows 10 or later if not being run on the same machine as MailEssensials.

 

Solution

The rest of the article provides solutions depending on whether you are using a Microsoft Outlook profile (PST file) or a Microsoft Exchange mailbox.

Follow the instructions depending on where the existing emails are located:

Microsoft Outlook profile

If the Bayesian Wizard is being run on a Microsoft Outlook profile, the Microsoft Outlook profile needs to be removed from Microsoft Outlook and recreated. This can be done as follows:

  1. From the Control Panel, open the Mail Control Panel.
  2. Select Show Profiles.
  3. Remove all the profiles.
  4. Add a new profile by clicking the Add button.
  5. Configure the new profile so that it accesses the mailbox required.

Microsoft Exchange mailbox

Option 1

Ensure that Secure Sockets Layer (SSL) is disabled when running the Bayesian Wizard. This can be done as follows:

  1. Open Internet Service Manager.
  2. Go to Default Web Site. Right-click Exchange and select Properties. Choose the Directory Security tab.
  3. In the 'Secure Communications' section, click the Edit button.
  4. Disable 'Require SSL'.
  5. Restart the 'World Wide Web Publishing' service.
  6. Check if the problem persists. If the problem persists, please proceed to Option 2.

Option 2

Install Microsoft Outlook on a separate machine (an existing Microsoft Outlook installation on the Microsoft Exchange server machine may also be used). Configure Microsoft Outlook to connect to the Microsoft Exchange mailbox as follows:

  1. From the Control Panel, open the Mail Control Panel.
  2. Select Show Profiles.
  3. Add a new profile by clicking the Add button (or configure an existing profile).
  4. Configure the new profile so that it accesses the mailbox required. 

You will need to install the Bayesian Wizard on the machine running Microsoft Outlook. This procedure is detailed in the GFI MailEssentials user manual as well as in this linked article: How to train, manually update and create a new database for the Bayesian Filter.

Run the Bayesian Wizard on the machine running Microsoft Outlook and select to retrieve information from the Microsoft Outlook Profile. Note that Microsoft Outlook needs to be open during this process.

 

Confirmation

There should be no more folder enumeration issues when using the Bayesian Wizard to retrieve information from either a Microsoft Outlook profile or a Microsoft Exchange mailbox.

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  1. Priyanka Bhotika

  2. Posted
  3. Updated

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