Overview
Items cannot be saved to the Quarantine. Numerous errors like the following can be found in the Quar.gfi_log.txt file:
2011-09-15,15:01:18,152,1,"#00000928","#0000001F","info ","Quar","QuarInit..."
2011-09-15,15:01:18,152,1,"#00000928","#0000001F","error ","Quar","error:Database Error! Try Repairing the Database using esentutl.exe : Failed to Begin Session JET_errInvalidParameter, Invalid API parameter"
The following errors can also be found in the QASCoordinator log:
2011-09-15,13:37:39,090,1,"#00000928","#0000000C","info ","QAS Coordinator","ProcessMessage: Plugin[Quar.QA.QuarantineAction] Id[2048] is going to process the message..."
2011-09-15,13:37:39,105,1,"#00000928","#0000000C","error ","QAS Coordinator","ERROR: Process failed for plugin[Quar.QA.QuarantineAction]"
2011-09-15,13:37:39,105,1,"#00000928","#0000000C","info ","QAS Coordinator","Current actions flag: 2048"
2011-09-15,13:37:39,105,1,"#00000928","#0000000C","info ","QAS Coordinator","Current actions flag (after traversing actions): 2048"
2011-09-15,13:37:39,105,1,"#00000928","#0000000C","info ","QAS Coordinator","Item failed to be processed by pluginID [2048] during Current actions"
2011-09-15,13:37:39,105,1,"#00000928","#0000000C","error ","QAS Coordinator","ERROR: ProcessMessage: Item with message-id[<CURMAIL189QtpfTYSl1000008ca@mail.mcb-bank.com>] will be stored in the Recovery queue"
2011-09-15,13:37:39,105,1,"#00000928","#0000000C","info ","QAS Coordinator","ProcessMessage: aborting MSMQ transaction..."
2011-09-15,13:37:39,215,1,"#00000928","#0000000C","info ","QAS Coordinator","ProcessMessage: aborting MSMQ transaction...ok"
Environment
- MailEssentials
- All Supported Environments
Root Cause
Corruption within the quarantine.edb file. When .edb files are repaired, the log data is sometimes pulled back into the database and if that too is corrupted, the database will be corrupted again.
Resolution
- Stop all GFI MailEssentials services (Disable the Scan Engine).
- Go to ../GFI/MailEssentials/Quarantine or wherever the quarantine is located.
- Rename the /Logs folder to /Logs_old.
- Run a repair on the quarantine.edb file by navigating to it in the command prompt, and typing
esentutl /p quarantine.edb
. The/p
parameter repairs the database. If need be, run the/d
parameter as well to defragment the database. - Start all GFI MailEssentials services.
Confirmation
The quarantine logs should no longer show these errors, and emails should be able to be saved to the quarantine again.