Overview
All inbound emails are whitelisted even though there is no whitelist entry for the email address or domain.
Root Cause
Blank entries in the antispam2_whitelist
table.
Resolution
Follow these steps to determine whether the blank entries are causing the problem:
- Open the following file in any text editor:
...\GFI\MailEssentials\Antispam\DebugLogs\ase_whitelist.gfi_log.txt
- Search the file for the following (with the quotes):
entry IN ('')"
. The following is an example what to look for:2012-04-09,23:26:34,459,3,"#00001174","#0000152c","info ","ase_whitelist","SQL: SELECT TOP 1 id FROM antispam2_whitelist WHERE (type=1 OR type=5) AND entry IN ('')"
2012-04-09,23:26:34,459,3,"#00001174","#0000152c","info ","ase_whitelist","[MIMEFromWhitelist] Found match in db ..."
To resolve the issue, follow these steps:
- Stop the GFI MailEssentials services.
- Open the
config.mdb
database with Microsoft Access. - Open the
antispam2_whitelist
table. - Sort the entry column from A to Z.
- Delete any potential blank entries.
- Start the services stopped in step 1.