Overview
After updating Microsoft Exchange 2013 to the latest Cumulative Update, the Microsoft Exchange Transport Service does not start or stops shortly after starting.
Environment
Microsoft Exchange Server 2013 with GFI MailEssentials installed on the same server.
Root Cause
Changes to the Microsoft Exchange Agents during the updates.
Resolution
The following process should be run when updating Microsoft Exchange to prevent this type of issue (go to step 6 if you have already updated Microsoft Exchange):
- Disable email processing via the GFI MailEssentials Switchboard.
- Stop GFI MailEssentials services and set them to disabled.
- Update Microsoft Exchange.
- Enable and Start the GFI MailEssentials Services and email processing.
- Open a Command Prompt and browse to
...\GFI\MailEssentials\
- Run the e2k7 wizard to reinstall the agents and refresh the GFI MailEssentials settings, by running the following command:
e2k7wiz.exe clean
Note:
Should the Microsoft Exchange updates include changes to the Transport Agents, the E2k7 Wizard should be run (see step 6).
If this does not resolve your issue, please contact GFI Customer Support.