Answer
PROBLEM
SMTP level filters do not apply on emails downloaded by GFI MailEssentials Pop2Exchange.ENVIRONMENT
- GFI MailEssentials
- all supported environments
SOLUTION
Change the settings in Directory Harvesting module to let it run in full email mode. Please follow the steps below:- Open the MailEssentials Configuration
- Select Anti Spam > Filter Priority > SMTP Transmission Filtering and change to Full Email Mode
CAUSE
GFI MailEssentials Pop2Exchange downloads an email from the POP3 server, it analyzes the header, it checks if the recipient is present in the local domain and places the email in the Microsoft Exchange pickup folder (if applicable). From there the email is handled by Microsoft Exchange server and it passes the email to GFI MailEssentials agent for further processing. Once it has completed the job, it delivers it back to Microsoft Exchange server (if applicable).
Since the email does not pass through the SMTP level, SMTP level filters such as Greylisting and Directory Harvesting in SMTP mode will not function for these emails.
You may also notice that NDRs are now created by Exchange and sent out. This occurs due to the Directory Harvesting check not being made on any of the Pop3 emails by MailEssentials.