Answer
PROBLEM
Scan result shows Blocked [Whitelist] and the Recipient(s) as n/a
ENVIRONMENT
- GFI MailEssentials
- All supported environments
SOLUTION
- Gather the config.mdb (stored in the GFI MailEssentials root folder)
- Open the database in Microsoft Access
- Navigate to actions table
- Change the action flag number to 256 for Whitelist (if logging is enabled add the value to 320
- Save the changes in the database
- Compact and repair before replacing the database
To replace the file:
- Stop all GFI MailEssentials Services and IIS Admin Service
-
Navigate to ..\Program Files\GFI\MailEssentials\Antispam
- Rename config.mdb to cconfig.old
- Replace with the new config.mdb
- Start all GFI MailEssentials services and the IIS Admin Service
CAUSE
The action flag was set incorrectly in the configuration database.