Answer
PROBLEM
Reports.mdb has become too large and space is required on the install drive
ENVIRONMENT
- GFI MailEssentials
- Microsoft Access
SOLUTION
Shrink the database in MS Access:
- Stop the GFI MailEssentials MailSecurity Services
- Copy the Reports.mdb to a server that has MS Access
- Open the database in Access and select the File tab
- Choose "Compact & Repair" and click Save when completed
- Replace the original reports.mdb on the ME server with the newly compacted one
- Restart the MailEssentials Services
Backup or Delete the Database
- Stop the GFI MailEssentials Services
- Either copy the Reports.mdb to another drive or delete it
- Restart the GFI MailEssentials (a new, empty database will be created to replace it)
- NOTE: After a Report Database reaches it maximum size of 2 gigabytes, it will automatically roll into another file. Check to make sure you do not have older back up databases in the directory as these may also be taking up needed space. The backup databases will have a date/time stamp affixed to them. They can be safely moved or deleted
- Starting with MailEssentials 2014r2 (Build 20140627) MailEssentials will no longer use Access for reporting and will be moving to a firebird database.
CAUSE
The reporting databases cannot currently be disabled and can grow large. Backup copies of old databases may also be present, consuming needed hard disk space.