Overview
This article provides some recommended housekeeping procedures to be followed in case there is intermittent mail flow after MailEssentials is installed or upgraded, often due to the GFI Services failing to start successfully.
Some of the reasons why MailEssentials services may crash resulting in interrupted mail flow include but are not limited to:
- A software component from either Microsoft Exchange, MailEssentials, or another software service involved in mail flow (such as the IIS SMTP Service, Exchange Transport Agents, etc) is crashing or failing to start successfully due to unfulfilled dependencies.
- Third-party software such as an anti-virus or backup software is locking the Information store and preventing MailEssentials from routing mail to it.
Diagnosis
Some of the symptoms to look out for when there is intermittent mail flow include:
- Mails going to the FailedMails folder and not being delivered to the users' mailboxes
- MailEssentials services failing to start successfully / crashing
- Patches failing to install successfully and getting stuck on 'Installing'.
- Virus Scanning Engines failing to update
Solution
When any of the above symptoms are experienced, follow the below housekeeping steps. It is advisable to do this while tracing is enabled in order to provide the troubleshooter logs to the GFI Support team in case mail flow is not restored for further investigation.
Follow the below steps when troubleshooting mail flow:
- Temporarily disable MailEssentials from processing email by following the steps described in Enabling or Disabling GFI MailEssentials Processing. This step will ensure that troubleshooting effort is focused on the root cause as it will quickly determine if the issue is within MailEssentials or elsewhere in the mail delivery chain. Proceed once you confirm the problem is within MailEssensials.
- Older releases of the product have known issues that were resolved in subsequent releases hence it is always recommended to upgrade to the latest build by checking the GFI Upgrade Center.
- Restart GFI MailEssentials services and check if mail flow is restored. The full list of services is available in Services Installed by MailEssentials.
- Restart either the IIS SMTP or Exchange Transport service (depending on your deployment scenario) to see if mail flow gets restored.
- If the Exchange Transport service fails to start because of the 'Invalid agent assembly path' error, check to see if MailEssentials is installed in a drive other than the default C: drive. If it is, make sure that the Network Service account has full control permissions over the MailEssentials install folder. By default, it does not thereby causing the Transport service to fail when it uses that account to read the agent DLL. The detailed error that will be seen in the Application Event logs is:
- Failed to create agent factory for the agent 'GfiAsSmtpAgent' with error 'Failed to create type 'ContentSecurity.ExchangeAgents.GfiAsSmtpAgentFactory' from assembly 'D:\Program Files\GFI\ContentSecurity.ExchangeAgents.gfiassmtpagent.dll' due to error 'Invalid agent assembly path.', 'Please verify the corresponding transport agent assembly and dependencies with the correct version are installed.'
- The above error can be caused by Anti-Virus software blocking the installation of the agents DLLs. Disable the anti-virus software and reinstall MailEssentials.
- If the error persists run the following PowerShell script to reinstall the transport agents:
C:\Program Files\Microsoft\ExchangeServer\v14\scripts\reinstalldefaulttransportagents.ps1
- If you have Anti-virus and Backup software on the MailEssentials server, remember to configure the Recommended Antivirus and Backup Exclusions to rule out any unintended interference. Windows Defender, in particular, is known to cause the MailEssentials Decompression Engine to quarantine legitimate emails as described in this article.
- Find out where the mail is building up. Use the Exchange Queue Viewer and MailEssentials Dashboard to see if anything is building up in any particular queue or taking any particular action. At the same time, check the FailedMails and Global Actions folders.
- If restarting services does not resolve the issue, run the
stop_snks.cmd
ordisable_agents.cmd
scripts located in the ...\GFI\MailEssentials\Antispam folder to unbind the MailEssentials sinks/agents and then restart the GFI MailEssentials Attendant Service. - If mail is still not flowing, check to see if other programs (such as MailSecurity, Anti-virus, or backup software) is installed that may be interfering with mail flow or the Information/Mail store. On the same note, check the application event logs to see if any programs are actually crashing and the reasons why.
- If you are using Exchange 2007 or 2010, check the Transport Agents currently installed. They may be causing an issue with MailEssentials Transport Agents. You can check this by opening the Exchange Management Shell and typing the command
get-transportagent
to see what other agents are installed. If there are any other antispam or antivirus agents listed, try to disable them one at a time and restart the Transport service to see if they are conflicting. - If no programs are interfering with mail flow and all previous steps have been taken please gather troubleshooter logs by following the steps described in Creating and Submitting Troubleshooting Logs for GFI MailEssentials for further root cause analysis.
- Submit a support request GFI Support detailing the issue experienced and provide the troubleshooter logs collected above.
Related Articles