Answer
PROBLEM
Legitimate emails are blocked by Directory Harvesting.
ENVIRONMENT
SOLUTION
- Check to make sure that the domain name is entered properly in the General Settings. Usually this issue is caused by a simple typo of the domain name.
- If the domain is correct, make sure that the emails which are being blocked are intended for this domain. If there are more than one domains that are supposed to be filtered, confirm that as well.
- Test both a valid and an invalid email address within the MailEssentials configuration in the Directory Harvesting properties.
- If the test is successful or failed and is accurate and the false positives are still being blocked, it is helpful to check the usercntvsapi log in the DebugLogs folder if it is present to find out if there are any AD issues. There might be a port blocked or some other issue that is preventing AD lookups.
- If installed on a relay or using LDAP settings Try using the Global Catalog port 3268 (Verify that port 3268 is not blocked by a firewall)
- If these checks have been done and there is still a problem, escalate the case to PSG.
CAUSE
Usually a typo of the domain name, or a blockage of the AD query.