Answer
PROBLEM
- A definition in the engine is corrupt and is not allowing the Auto updates to complete successfully
- Items will land in the Failed mails folder when the Engine will fail to Initialize
ENVIRONMENT
- GFI MailEssentials
- All supported environments
SOLUTION
There are two ways to initiate the update.Solution 1
- Navigate to the following directory <GFI MailEssentials installation path>\GFI\MailEssentials\Updater\avx
Delete the following files:
- bitdefender_current_revision.txt
- bitdefender_current_revision.txt.checked
- bitdefender_current_revision.txt.tmp
- Open Services.msc and restart the GFI MailEssentials AV Scan Engine and GFI MailEssentials Autoupdater services.
- Open MailEssentials Configuration and navigate the dropdowns to Email Security > Virus Scanning Engine > BitDefender > Updates.
- Click Download Updates and click Apply.
- Verify that the definitions successfully installed on the Update status section.
If the above steps do not update the definitions a manual update is required in order to clear the possible corrupt definitions out of the MailEssentials directories. Follow the steps below in order to complete the manual update process.
- Open a browser and navigate to http://cdnupdate.gfi.com/
- Once logged in navigate to the following directory incav2 > bitdefender > C1 folder and click the bitdefender_current_version.c1.zip link to download the latest Bitdefender Definitions.
- After the download has completed you will need to navigate to service.msc and stop the SMTP or transport service(note this will stop mail flow and queue the messages in exchange until restarted)
- In services.msc console locate and stop all gfi services related to MailEssentials
- Extract the downloaded zip from step 2 to the following location <GFI MailEssentials installation path>\GFI\MailEssentials\Updater\avx overwrite when prompted by windows
- Navigate to the directory where you just extracted the files to from the previous step <GFI MailEssentials installation path>\GFI\MailEssentials\Updater\avx and locate the file bitdefender.zip
- Extract the bitdefender.zip to the following locations: <GFI MailEssentials installation path>\GFI\MailEssentials\AntiVirus\avx and <GFI MailEssentials installation path>\GFI\MailEssentials\AntiVirus\backup\avx overwrite when prompted
- Restart all services stopped in step 3 and 4.
- Open MailEssentials configuration and verify that the Bitdefender Engine has been updated Successfully with the latest version
CAUSE
- The definitions files were corrupted and that can cause update failures.
- Third party antivirus or backup scanning of the GFI MailEssentials folders can corrupt definitions.
- Content filter type Hardware firewalls can corrupt the MD5 checksum during the update process please verify the proper exclusions are in your hardware firewall for successful updates. Please see the following article for the current update sites needed to be excluded in your firewall. https://www.gfi.com/support/products/gfi-mailessentials/What-sites-are-used-for-GFI-Product-Updates