Answer
PROBLEM
- A definition in the engine is corrupt and is not allowing the Auto updates to complete successfully
- Items will land in the Failed mails folder when the Engine will fail to Initialize
ENVIRONMENT
- GFI MailEssentials
- All supported environments
SOLUTION
There are two ways to initiate the update.Solution 1
- Navigate to the following directory <GFI MailEssentials installation path>\GFI\MailEssentials\Updater\Avira and delete the following files:
- avira_current_revision.txt
- avira_current_revision.txt.checked
- avira_current_revision.txt.tmp
- Open services.msc and restart the GFI MailEssentials AV Scan Engine and GFI MailEssentials Autoupdater service
- Open GFI MailEssentials configuration and navigate to Email Security > Virus Scanning Engines > Avira > Updates.
- Click Download Updates and click Apply.
- Verify that the definitions successfully installed on the Update status section
If the above steps do not update the definitions a manual update is required in order to clear the possible corrupt definitions out of the GFI MailEssentials directories. Follow the steps below in order to complete the manual update process.
- Open a browser and navigate to http://cdnupdate.gfi.com/
- Select the files that you need to update /incav2/avira/c1/avira_current_version_c1.zip.
- Open the service.msc and stop the SMTP or transport service. (Note this will stop mail flow and queue the messages in Exchange until restarted).
- In services.msc console locate and stop all services related to GFI MailEssentials.
- Extract the zip file to the <GFI MailEssentials installation path>\GFI\MailEssentials\Updater\Avira (overwrite when prompted)
- Browse to <GFI MailEssentials installation path>\GFI\MailEssentials\Updater\Avira
- Locate the zip file avira.zip.
- Extract the avira.zip to the following locations <GFI MailEssentials installation path>\GFI\MailEssentials\AntiVirus\avira and <GFI MailEssentials installation path>\GFI\MailEssentials\AntiVirus\backup\avira overwrite when prompted
- Restart all services stopped in step 3 and 4.
- Verify that the definitions are showing the new version
CAUSE
- The definitions files were corrupted and that can cause update failures.
- Third party antivirus or backup scanning of the GFI MailEssentials folders can corrupt definitions.
- Content filter type Hardware firewalls can corrupt the MD5 checksum during the update process please verify the proper exclusions are in your hardware firewall for successful updates.
- Please see the following article for the current update sites needed to be excluded in your firewall: https://www.gfi.com/support/products/gfi-mailessentials/What-sites-are-used-for-GFI-Product-Updates