Answer
PROBLEM
- High CPU usage or freezing when adding an entry to the Whitelist, Blacklist or Keyword list
- High CPU usage and long processing time for large emails
ENVIRONMENT
- GFI MailEssentials
- All Supported Environments
RESOLUTION
- Stop the GFI MailEssentials Services
- Open the config.mdb located in ..\GFI\MailEssentials in Microsoft Access
- Run a Compact and repair on the file
- Open the autowhitelist.mdb located in ..\GFI\MailEssentials in Microsoft Access (MailEssentials 2014 and previous only)
- Run a Compact and repair on the file (MailEssentials 2014 and previous only)
- Restart the GFI MailEssentials Services
If issues are still encountered:
- Open the config.mdb in Microsoft Access
- Check the antispam2_whitelist and antispam2_blacklist tables
- These tables should not have more then 10,000 items each
- Open the MailEssentials Configuration and check the amount of keywords in the Keyword blocklist
Note: If any changes to files are needed, stop the GFI MailEssentials services first, and restart them when finished.
It is also recommend no more then 30,000 entries in the autowhitelist.mdb. If you have more than this, sort by the time stamp and remove the older entries.
Note: Stop the GFI MailEssentials services first, and restart them when finished.
Note: Stop the GFI MailEssentials services first, and restart them when finished.
Open the MailEssentials Configuration > Anti Spam > Whitelist > Properties > Autowhitelist > Change the number in Maximum entries allowed in the Auto Whitelist to 30000.
CAUSE
The issue can be caused by a corruption in the database, or too many entries in the whitelist, domain or keyword blocklist.