Answer
PROBLEM
When trying to open the dashboard, the following error is given: 'Please make sure that GFI MailEssentials Managed Attendant Service is running'. The GFI MailEssentials Managed Attendant service is running.
The Dashboard application would fail to function (the window will be greyed out and a red X will be visible next to all listed services
The Dashboard application would fail to function (the window will be greyed out and a red X will be visible next to all listed services
ENVIRONMENT
- GFI MailEssentials
- All Supported Environments
SOLUTION
Check to see if port 8021 is in use by another application
1. Open a command prompt (cmd.exe) and type "netstat -abn > c:\gfiports.txt" without quotes.
2. Open gfiports.txt in a text editor and search for "8021".
3. Confirm which service is using this port. If anything other than "contentsecurity.as.attendant.exe" is running, then it confirms that there is a port conflict between the GFI MailEssentials application and a third party application.
If the dashboard logs show that it cannot connect to port ::1:8021, then it means the machine is set to use the IPv6 localhost, which MailEssentials cannot connect to. You would need to edit the host file to make sure that the ::1 address is commented out with a # mark.
Change the remoting port if in use
To resolve this issue, the GFI MailEssentials TCP remoting port can be changed to an alternate port. The instructions below explain how to do this:
1. Close all GFI MailEssentials applications (Configuration UI, Dashboard, etc.)
2. Open the following GFI MailEssentials configuration files in a text editor and replace port "8021" with any new free port number (i.e. 8121):
../GFI/MailEssentials/Data/rclientsettings.xml
../GFI/MailEssentials/Data/product.config
../GFI/MailEssentials/Quarantine/wwwroot/web.config
../GFI/MailEssentials/MiddleLayer/contentsecurity.as.remoting.exe.config
../GFI/MailEssentials/MiddleLayer/contentsecurity.as.attendant.exe.config
../GFI/MailEssentials/e2k7wiz.exe.config
../GFI/MailEssentials/meswitchboard.exe.config
../GFI/MailEssentials/dashboard.exe.config
NOTE: You may not have an rclientsettings.xml file in your installation. Please continue to the rest of the files.
3. Open regedit.exe and navigate to HKLM > Software > GFI > Config (x86 installations) or HKLM > Software > Wow6432node > GFI > Config (x64 installations). Change the port number of 8021 to your new port number for the following keys:
pftrainingurl
pftrainurlews
tickmanurl
4. Restart the GFI MailEssentials Managed Attendant service.
5. The GFI MailEssentials Dashboard application should now be operating on a remoting port other than 8021
5. The GFI MailEssentials Dashboard application should now be operating on a remoting port other than 8021
CAUSE
When multiple applications use the same TCP remoting port, the first application that is launched gets exclusivity over that TCP port. When the second application tries initialize using the same port, a "connection refused" error may be experienced. This is known as a port conflict.