Overview
The pop2exchange module is crashing with the following error:
Faulting application pop2exch.exe, version 10.0.0.50, time stamp 0x4d779382, faulting module pop2exch.exe, version 10.0.0.50, time stamp 0x4d779382, exception code 0xc000000d, fault offset 0x0001d886, process id 0x1db8, application start time 0x01cc373b726d39e2
Environment
- GFI MailEssentials
- All supported environments
Root Cause
Files being used by other programs can lead to file corruption. For example, during patch installations and anti-virus scanning, it is common for the file to get locked or corrupted.
To avoid this, it is always recommended to exclude the MailEssentials directories from scanning.
Resolution
- Browse to the installation folder of MailEssentials, by default:
..\Program Files\GFI\MailEssentials\DebugLogs
. In MailEssentials 2012, the path is..\Program Files\GFI\MailEssentials\Antispam\DebugLogs
(which is the same path used in other references in this article). - Open the log file MEDashBoardPlugin.log
- Look for a string similar to this:
Error: open_log_file(): System.IO.IOException: The process cannot access the file '\Program Files\GFI\MailEssentials\GFIMON\Popstru.log' because it is being used by another process.
If you find the above error or similar, please perform the following:
- Stop MailEssentials services, the IIS Admin service (including all dependencies) and the Exchange Transport Service (if present).
- Browse to the
...\Program Files\GFI\MailEssentials\GFIMON
folder. - Delete the log files present in this location.
- Browse to the
...\Program Files\GFI\MailEssentials\DebugLogs
folder. - Delete the log files present in this location.
- Restart all services stopped in step 1.
Note: These log files will be re-created by the system.