Answer
PROBLEM
After installing GFI MailEssentials in VSAPI mode on the same machine as Microsoft Exchange server, the backup software takes much longer to finish.
ENVIRONMENT
- GFI MailEssentials
- Installed directly on a Microsoft Exchange server
SOLUTION
Do one of the following:
- Since the problem will occur mostly only on the first backup, and subsequent backups should have less un-scanned emails, you can decide to let the backup run with MailEssentials enabled, allowing the backup to take a bit longer.
- Perform a Manual Scan of the Microsoft Exchange Information Store with MailEssentials before performing the backup. This will ensure that there are no items in the Microsoft Exchange Information Store that are not scanned and therefore the backup should take the same amount of time as when MailEssentials are disabled.
- Disable the VS API functionality in MailEssentials during the backup. This is done if the backup is taking longer than expected each time that a backup is performed. You can disable the VS API functionality using a Visual Basic Script (VBScript) downloadable from http://ftp.gfisoftware.com/support/me/Skynet/vsapicontrol2.zip. The following information shows how to use this utility.
The downloaded vsapicontrol2.vbs script supports the following parameters:
start: used to start VSAPI
stop: used to stop VSAPI
Follow this procedure to disable VSAPI automatically before the backup and re-enable it once the backup is finished.
- Run "vsapicontrol2.vbs stop"
- Run the backup
- Run "vsapicontrol2.vbs start". This will start VSAPI once again
The above can either be placed in a batch file, or the backup software may allow you to run the VBScript before the backup commences, and after it finishes.. It is recommended to monitor the first backup so that you ensure that the procedure is working correctly.
CAUSE
GFI MailEssentials, by default, does not scan all the items in the Microsoft Exchange Information Store. Only new items and items which are being accessed by the users and are still un-scanned will be scanned by MailEssentials.
However, when a backup of the Information Store is being performed, the backup will retrieve the emails from the mailboxes to perform the backup. When doing so, MailEssentials will scan all messages that are still un-scanned. This will cause the backup to take longer to finish.
Notes:
- When VSAPI is disabled, emails can still be received if the Microsoft Exchange Information Store or the Simple Mail Transport Protocol (SMTP) services are running. These emails can still be downloaded by the users. Internal emails received and downloaded during the backup, while VS API is disabled, will NOT be scanned for viruses by MailEssentials in VS API mode. On the other hand, Inbound and Outbound mails will be fully scanned, since Inbound and Outbound emails are also scanned at SMTP level.
- It is recommended to run the backup during the night when no users are logged into the system while VS API is disabled.