Answer
PROBLEM
After installing or upgrading to GFI MailEssentials 2014 R2 the GFI MailEssentials services are crashing and failing to start. Hence, email flow stops and the services of Microsoft Exchange server and MSMQ might stop as well.How to identify
- The following GFI MailEssentials services fail to start: List Server, Backend, Legacy Attendant, Quarantine Action
- From the Microsoft Windows Events viewer:
- The Backend Service fails to start (event ID 5106):
Unknown runtime execution error: Remoting configuration failed with the exception 'System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.Net.Sockets.SocketException: Der Zugriff auf einen Socket war aufgrund der Zugriffsrechte des Sockets unzulässig
at System.Net.Sockets.Socket.DoBind(EndPoint endPointSnapshot, SocketAddress socketAddress)
at System.Net.Sockets.Socket.Bind(EndPoint localEP)
at System.Net.Sockets.TcpListener.Start(Int32 backlog)
at System.Runtime.Remoting.Channels.ExclusiveTcpListener.Start(Boolean exclusiveAddressUse)
at System.Runtime.Remoting.Channels.Tcp.TcpServerChannel.StartListening(Object data)
(...)
at System.Net.Sockets.Socket.DoBind(EndPoint endPointSnapshot, SocketAddress socketAddress)
at System.Net.Sockets.Socket.Bind(EndPoint localEP)
at System.Net.Sockets.TcpListener.Start(Int32 backlog)
at System.Runtime.Remoting.Channels.ExclusiveTcpListener.Start(Boolean exclusiveAddressUse)
at System.Runtime.Remoting.Channels.Tcp.TcpServerChannel.StartListening(Object data)
(...)
- Listserver is crashing:
Faulting application name: listserv.exe, version: 18.0.1181.5, time stamp: 0x53ad9a4d
Faulting module name: lsQ.dll, version: 18.0.1181.2, time stamp: 0x53ad983c
Exception code: 0xc0000005
Fault offset: 0x000063a2
Faulting process id: 0x3b1c
Faulting application start time: 0x01cfdee69b5653cd Faulting application path: C:\Program Files (x86)\GFI\MailEssentials\Antispam\listserv.exe
Faulting module path: C:\Program Files (x86)\GFI\MailEssentials\Antispam\lsQ.dll
Faulting module name: lsQ.dll, version: 18.0.1181.2, time stamp: 0x53ad983c
Exception code: 0xc0000005
Fault offset: 0x000063a2
Faulting process id: 0x3b1c
Faulting application start time: 0x01cfdee69b5653cd Faulting application path: C:\Program Files (x86)\GFI\MailEssentials\Antispam\listserv.exe
Faulting module path: C:\Program Files (x86)\GFI\MailEssentials\Antispam\lsQ.dll
- From the debug logs:
AttendantService.log and RemotingHelper.log (in any Debug Log folder) showing Remoting Exceptions:
...,"error ","Attendant Service","Error: OnStart. Unhandled error: System.Runtime.Remoting.RemotingException: Remoting configuration failed with the exception 'System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.Net.Sockets.SocketException: Der Zugriff auf einen Socket war aufgrund der Zugriffsrechte des Sockets unzulässig
; at System.Net.Sockets.Socket.DoBind(EndPoint endPointSnapshot, SocketAddress socketAddress)
(...)
; at System.Net.Sockets.Socket.DoBind(EndPoint endPointSnapshot, SocketAddress socketAddress)
(...)
...,"error ","RemotingHelper","Error: UploadUsageInfo() - System.Runtime.Remoting.RemotingException: Die zugrunde liegende Verbindung wurde geschlossen: Entweder ist auf dem Server ein schwerwiegender Fehler aufgetreten, oder die Clientauthentifizierung ist fehlgeschlagen.
(...)
(...)
- Check in Services if Symantec Endpoint Protection Manager and in the Windows Task Manager if SemSvc.exe is running.
ENVIRONMENT
- GFI MailEssentials 2014 R2 (Build 20140627)
- Symantec Endpoint Protection 11.0
- Both installed on the same server
SOLUTION
Solution 1:Change the Backend Remoting Port in the GFI MailEssential Switchboard from 9090 to something else, which is not in use (e.g.9093).
A port conflict is present, if the dot next to the port is red. If the dot is green, the port is free and there are no conflicts.
Solution 2:
Upgrade to MailEssentials 2015 or higher (the Backend port was changed in this release).
Reference: What ports are used by GFI MailEssentials?
CAUSE
The default remoting port of the GFI MailEssentials Backend service is listening on the same port as the Symantec Endpoint Protection 11.0 process (called SemSvc.exe). Reference: http://www.symantec.com/business/support/index?page=content&id=TECH102416