Overview
MailEssentials uses Microsoft ESE (Extensible Storage Engine) databases (aka JetBlue) for the Anti-Spam Quarantine Store as well as for the Greylisting database.
This article describes the process to follow when the Quarantine Store or Greylisting database is corrupt.
Diagnosis
It can occur that an ESE database becomes corrupted. In the case of Greylisting, no critical information is lost if the database becomes corrupt. When the customer creates a new Greylisting Database, MailEssentials would only need to learn the triplets from scratch.
However, if the Quarantine Database becomes corrupted it is possible that false-positive spam emails would be lost therefore it is recommended to attempt repairing as the first troubleshooting step.
The possible causes of a database corruption are varied but the common ones include:
- Hard drive issues leading to file system corruption.
- Abrupt system shut down while the database is in use.
- Virus and malware infections.
- Software or operating system upgrade resulting in file corruption.
This next section provides the steps to be followed to repair a corrupted Quarantine Store database and recover emails that had been quarantined. If however, the steps described here fail, you will have to re-create the Quarantine store as described in this linked article: How to recreate the GFI MailEssentials Antispam Quarantine database
Some of the possible symptoms of a corrupted Quarantine store database include:
- The Antispam Quarantine interface cannot be launched or displays errors.
- Quarantine reports are not delivered.
- A severe delay in the delivery of emails.
- Errors in the debug logs related to the Quarantine store
Solution
Microsoft Windows operating system provides a built-in command-line utility named Esentutl for managing Extensible Storage Engine (ESE) files (JET Blue databases).
To run esentutl, open a command prompt, type esentutl with the appropriate parameters, and then press ENTER.
Esentutl.exe can be used to repair the corrupt Quarantine database. The following procedure explains how to use this Microsoft Windows Utility to repair the database.
- Stop the GFI MailEssentials Managed Attendant service.
- Go to Start > Run > %temp% and delete all JET*.tmp files in this folder and the temp folder. Note that sometimes
%temp%
opens to a subfolder in the main TEMP folder. - Create a backup of the database to be repaired.
- By default, the quarantine database is located in
..\GFI\MailEssentials\Antispam\Quarantine\quarantine.edb
. - By default, the greylisting database is located in
..\GFI\MailEssentials\Antispam\data\greylisting.db
.
- By default, the quarantine database is located in
- From command prompt, change the path to the folder of the Quarantine Store database or Greylist database.
- To repair the database, enter the following command:
esentutl /p databasename.edb
. Replacedatabasename
with the name of the database to be repaired. For example,esentutl /p quarantine.edb
- A warning message indicates that this process should only be performed on a corrupted database file.
- Click OK to start the integrity check.
- Start the GFI MailEssentials Managed Attendant service.
Confirmation
Once the repair is successfully completed and the GFI MailEssentials Managed Attendant service restarted, you should be able to successfully navigate to the Quarantine node (GFI MailEssentials > Quarantine) on the UI without error messages.