Overview
Fix incorrectly identified roles due to DC connectivity.
Root Cause
The root cause is a cache mechanism implemented in the product that starts at the beginning, then refreshes every 20 minutes. If at the beginning of the service startup, AD was not available yet, the cache would be empty for 20 minutes.
Resolution
The caching refresh logic has been improved and fixed in the 21.5 build.
The release notes for this build don't include this entry, as it's under "Several other minor improvements".
Upgrade to at least build 21.5 to correct this behavior.
Workaround
If the upgrade is not possible at the moment:
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Ensure that the domain controller is reachable from the MailEssentials server.
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Restart the GFI MailEssentials Attendant service.
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This will prompt to restart all other GFI MailEssentials services.
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Refresh the browser and log in.
If debugging is enabled, the information is logged under: ...\GFI\MailEssentials\Attendant\debuglogs\PermissionCache.log
.
Validation
The UI displays the full view.