Overview
Directory Harvesting is not filtering any spam. Neither the Dashboard nor the Statistics page shows Directory Harvesting filtering of any or just a few emails.
Also, the Directory Harvesting threshold is set to 1
and there are no errors in the logs.
Environment
- GFI MailEssentials
- Microsoft Exchange
Root Cause
Microsoft Exchange Recipient Filtering is enabled.
Resolution
- Check if the Microsoft Exchange Recipient Filtering is enabled.
NOTE: Exchange Recipient Filtering acts in the same way as Directory Harvesting.
- Since Exchange Recipient Filtering blocks the email already after the SMTP
RCTP TO
command, MailEssentials Directory Harvesting would not even "see" the message. Directory Harvesting would only block the email after the SMTPDATA
command.
- There is no real advantage to disable Exchange Recipient Filtering and use Directory Harvesting unless the MailEssentials Listserver is used.
- Since the Listserver email address is not known to the Exchange Recipient Filtering, it would block the emails addressed to the Listserver and Directory Harvesting would need to be used.