Answer
PROBLEM
Directory Harvesting is enabled in SMTP mode and nothing is showing up in the Dashboard or in the Directory Harvesting Logs.
ENVIRONMENT
- GFI MailEssentials
- Microsoft Exchange
- All supported environments
SOLUTION
- Ensure mail Is flowing through the Dashboard
- Open Exchange Management Shell (EMS) type the following cmdlet:
Get-TransportAgent
- Look for Recipient Filter Agent. This can be filtering at the SMTP level before our Agent can receive the mail.
- In the EMS, run the following command:
Disable-TransportAgent 'Recipient Filter Agent'
- Please note that this will remove Exchange's version of Directory Harvesting from the email reception process. It will need to be re-enabled the same way if you wish to have Exchange do the filtering.
- Restart the Microsoft Exchange Transport service in order for this action to complete
CAUSE
Recipient Filtering is a new feature in Exchange 2010. This works the same way as Directory Harvesting and can filter at the SMTP Protocol level. This is an Exchange function and will filter before MailEssentials has an opportunity to apply its own Directory Harvesting filter.For additional information, please refer to the following: http://technet.microsoft.com/en-us/library/bb123891.aspx