Answer
PROBLEM
Public Folder Replication is blocked when MailEssentials is installed
ENVIRONMENT
- GFI MailEssentials
- All supported environments
SOLUTION
To determine which is blocking the replication do the following:
- Open the GFI MailEssentials Configuration > Dashboard > Logs
- Check which filter is blocking the replication emails
Directory Harvesting:
In GFI MailEssentials:- Browse to the GFI MailEssentials installation directory (default C:\Program Files (x86)\GFI\MailEssentials\AntiSpam)
- Locate the config.mdb
- Open the config.mdb in Microsoft Access or OpenOffice Base
- Open the tb_dirharv_exclusions table
- Add the email address sending the public folder replication emails.
Greylisting:
Greylisting cannot be changed to full email mode and cannot be moved in Filter Priority. In order to ensure that Public Folder Replcation will work with this feature:
- Open the GFI MailEssentials Configuration > Anti Spam > Anti Spam Filters > Greylisting > Exclusions
- Add your domain to the Greylist exceptions
CAUSE
Public folder replication can be stopped by Greylisting and Directory Harvesting. This is because Public folders aren't RFC compliant (Greylisting) and there's no actual mailbox for them. Directory Harvesting fails and will also block the replication.