Answer
PROBLEM
Inbound emails are blocked after the DNSBL option has been enabled.
ENVIRONMENT
- Microsoft Exchange
- All supported environments
SOLUTION
Please ensure that only operational blocklists are configured and listed under the filter properties.
CAUSE
This issue will occur if using a DNS blocklist which has ceased to operate and answers all requests with a positive result. If using a non-existent list, all emails which are not whitelisted will be blocked.