Overview
Greylisting is not functioning properly and throws the following error in the debug logs:
error ","ase_greylisting","Failed to initialise successfully."
Environment
- GFI MailEssentials
- All supported environments
Root Cause
It is either the corrupted database or the related log file.
Resolution
- Delete the contents from the
...\MailEssentials\Antispam\Data\Greylisting
logs folder. - If that does not resolve the issue, then stop the GFI MailEssentials Anti-Spam (AS) Scanning Engine service. Move the greylisting.db file into the
...\MailEssentials\Antispam\Data\
folder to another location and restart the GFI MailEssentials AS Scanning Engine service.
NOTE: This procedure will wipe out the currently greylisting stored data but it will not wipe out any exclusions that have been set for email addresses.