Overview
When an email is blocked as spam by GFI MailEssentials and is moved to the subfolder of the user's inbox, there is no identification as to why the email is blocked.
Environment
- GFI MailEssentials
- All supported environments
Root Cause
GFI MailEssentials does not add the block reason to the subject of spam email by default.
Resolution
By default, when GFI MailEssentials is configured to save the emails to the user's Microsoft Exchange mailboxes, the reason why a message was blocked is not displayed in the subject of the message. GFI MailEssentials can be configured to start displaying the reason of why a message is blocked as follows:
- Open
regedit
. - Navigate to:
-
GFI MailEssentials x86 -
HKEY_LOCAL_MACHINE\SOFTWARE\GFI\MailEssentials\Antispam\Config
-
GFI MailEssentials x64 -
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\GFI\MailEssentials\Antispam\Config
-
GFI MailEssentials x86 -
- Change the block reason dword value from
0
to1
. - Close
regedit
. - Restart the Internet Information Services (IIS) Admin Service and all its dependencies.
More Information
The above information does not apply when spam is moved to the user's Microsoft Outlook Junk Email Folder (Exchange 2003). However, the following workaround is possible:
- Open the GFI MailEssentials Configuration.
- Open the Properties of the Anti-Spam feature that you need to configure.
- In the Actions tab, select the option to 'Move to Subfolder' and enter Junk Email. This will cause all spam emails (other than those intended for the public folders) to still be sent to the Junk Email folder in Outlook.