Overview
Corrupted definitions can sometimes cause the Trojan & Executable Scanner or the Email Exploit Engine to fail to correctly initialize or successfully complete the automatic updates. Both engines are part of the Email Security module.
This article describes how to determine if a manual update for these engines is necessary and provides an index to the articles detailing the manual update procedure.
Diagnosis
Automatic updates for the Trojan & Executable Scanner or the Email Exploit Engine will be unsuccessful if they are corrupted by a firewall or the definitions did not get successfully applied to the engines. Improper exclusions for file-based backups and 3rd party anti-virus scanners can also result in corrupt definitions and failed automatic updates.
The administrator can determine if a manual update is necessary by following these steps:
- Open the GFI MailEssentials Configuration
- Expand ‘EmailSecurity’ on the left pane
- Click on the ‘Trojan & Executable Scanner’ or the 'Email Exploit Engine' node on the left pane.
- Note: The engine that failed to update is also indicated in the email notification sent to the Administrator email for all failed updates.
- The ‘Updates’ tab will have a ‘Last Update’ date that is not recent. In addition, the Update Status section will have a notification stating that the last update failed.
More details on the reasons for the failed update can be extracted from the debug logs. Location and filename for the debug log files is shown below:
EmailSecurity Engine | Debug Log Filename & Location |
Trojan & Executable Scanner | ..\GFI\MailEssentials\EmailSecurity\DebugLogs\Trojan Scanner.gfi_log.txt |
Email Exploit Engine | ..\GFI\MailEssentials\EmailSecurity\DebugLogs\EmailExploit.gfi_log.txt |
Any errors that result in failing automatic updates will necessitate a manual update process as described in the next section.
Solution
A manual update must be performed on the engine that is failing to automatically update successfully.
Below is an index of the manual update procedure for each engine:
How to Manually update the Trojan and Executable scanner
How to Manually update the Email Exploit Engine
Confirmation
- Open the GFI MailEssentials Configuration
- Expand ‘EmailSecurity’ on the left pane
- Click on the ‘Trojan & Executable Scanner’ or the 'Email Exploit Engine' node on the left pane, depending on which one has been manually updated.
- The ‘Updates’ tab should have a recent ‘Last Update’ date. In addition, the Update Status section will have a notification stating that the last update succeeded.