Overview
This article describes the process to follow in case you are not able to save settings or settings are being reactivated after disabling in GFI MailEssentials.
Diagnosis
The reason for which the issue occurs is a large .mdb database or corrupt .mdb database.
Depending on where the setting you are trying to correct is located it will be in one of two files.
- Email Security or Content Filtering
- ..Program Files\GFI\MailEssentials\EmailSecurity\Data\avapicfg.mdb
- Antispam
- ..\Program Files\GFI\MailEssentials\Antispam\config.mdb
Solution
Depending on what setting you are trying to correct it will be in one of two files.
- Stop all the GFI MailEssentials Services and navigate to the appropriate folder for the setting you are having trouble with.
- Copy the config.mdb or avapicfg.mdb file and paste it to some secure location as a backup.
- Open the original .mdb file using Microsoft Access.
- In Microsoft Access, go to the Database Tools tab on the top, then select Compact and Repair. It will repair the .mdb file.
- Save the file and close the MS Access.
- Start all GFI MailEssentials services.
Testing
After performing the compact and repair, launch the Mail Essentials console and attempt to make the configuration change in question again. After saving the change, navigate away or close the console before launching a new instance. The setting should now have saved properly as it was able to be written to the newly repaired database.