Overview
In the settings field for each user, the credentials are populated, and 'remember credentials' is selected. If a user re-opens Outlook, the plug-in does not re-authenticate.
Solution
Root Cause
The SpamTag client has to authenticate first before it will be allowed to communicate with MailEssentials. The available authentication options are Windows and Forms, both over WCF.
The first authentication attempt is Windows Authentication (automatically).
Should the Windows authentication fail it will fall back on Forms authentication.
The cause for this can be due to environmental issues such as:
- Timezone offset between server and client
- Computers not in the same domain or network as the GFI server
- AD controller is not reachable
- Latency in VPN connection
Steps
Ensure that there are no environmental issues preventing Windows Authentication. Windows Authentication can be forced by removing the user and password in the plugin settings.
Notes
If the WCF endpoint needs to be updated in order to overcome any environmental issue, it can either be done directly from the SpamTag settings.
If this option is not available, it can be configured by modifying the Windows registry:
x86:
HKLM\SOFTWARE\GFI\MailEssentials\SpamTag
x86_64:
HKLM\SOFTWARE\Wow6432Node\GFI\MailEssentials\SpamTag
Update the key WebServiceURL
to point to the correct location, restart the client machine for the updated value to take effect, and flush the DNS cache. For more details, please read the Update the SpamTag web service URL article.