Overview
Legitimate emails like password reset emails are being blocked by the Greylist filter and there's no option to release them.
Root Cause
The Greylist filter may cause false positives. Since these emails are being identified at the SMTP level, they are not quarantined, so there is no option to release them.
Solution
The best way to find why greylist blocked a message is to review the logs which will help correct the behavior. There are two available solutions to this issue:
Enable exclusions for the Greylist filter
The Greylist allows you to configure exclusions, in order to reduce the number of false positives. If you know the specific IP or address that you want to exclude, please follow the steps presented in the Configuring the Greylist Filter article.
Additionally, you can check the option to Exclude email addresses and domains specified in Whitelist and Personal Whitelist, available in the Email Exclusions tab, in order to automatically exclude all previously whitelisted entries.
Disable the Greylist filter
Another solution is to disable the Greylist filter. If this approach is chosen, we recommend the following configuration steps in order to ensure that your environment stays protected:
Update the IP DNS blocklist
Please alter your IP DNS blocklist for optimal coverage. In MailEssentials go to the IP DNS blocklist. Ensure that bl.spamcop.net
and dul.dnsbl.sorbs.net
are enabled.
- Type
zen.spamhaus.org
in the Domain box and click Add IP DNS Blocklist. - Type
b.barracudacentral.org
in the Domain box and click Add IP DNS Blocklist. - Type
dnsrbl.org
in the Domain box and click Add IP DNS Blocklist. - Type
dnsbl.sorbs.net
in the Domain box and click Add IP DNS Blocklist. - Ensure the new lists are enabled and click Apply.
Open a browser and go to barracudacentral.org. Click the Request access link on the left. Fill out the form providing your external IP address in order to access the Barracuda Central blocklist.
Enable the Header Checking filter
The Header Checking filter will help identify spam emails by analyzing their headers.
Once this filter is active, we recommend enabling the following settings:
- "Check if the email header contains an empty MIME FROM: field."
- "Check if the email header contains a malformed MIME FROM: field."
- "Check if the email headers contain different SMTP TO: and MIME TO: fields."