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Approved Quarantined emails going to the C drive instead of the Exchange Pickup folder

Overview

This article describes the procedure to be followed when approved quarantined emails are not delivered to the Exchange Pickup folder and instead remain and continue to build-up on the C drive.

Diagnosis

  • When the user approves emails in the quarantine they are not delivered to Exchange and instead continue building up in the C drive which will show .eml messages building up.
  • This usually happens during the upgrade process when an incorrect version of Microsoft Exchange Server is detected or the Exchange pickup paths are not correctly configured.
  • When emails are released from Quarantine, they will be moved to the C: drive since MailEssentials cannot locate the Exchange Pickup Folder, usually C:\inetpub\mailroot\pickup.

Prerequisites

Environment

  • All GFI MailEssentials versions
  • Microsoft Exchange 2007 or later

Solution

There are two ways to fix the MailEssentials configuration when emails approved from the quarantine are not being delivered to the Exchange server.

Solution 1 - Recommended

Launch the post-installation wizard by following the below steps:

  1. Open a run window and
  2. Enter the following command:
    • C:\Program Files (x86)\GFI\MailEssentials\e2k7wiz.exe clean

Important:

  • The command needs to have the 'clean' parameter else it will just install/refresh the transport agents/sinks.
  • When using 'clean', the post-install wizard will ask the user to reconfigure/validate the general settings, particularly asking to choose a default AntiSpam action for the modules. Make a note of what actions were set to the AS filters in case they need to be changed.

Solution 2 - Manual configuration update

This option is recommended for advanced users as it involves updating the configuration files manually. The manual update avoids changing the already configured default AS Actions. You will require Microsoft Access to perform the below steps: 

  1. Obtain a copy of the config.mdb and the avapicfg.mdb from the server
  • config.mdb is located at ..\GFI\MailEssentials\Antispam
  • avapicfg.mdb is located at ..\GFI\MailEssentials\EmailSecurity\Data
  1. Open the config.mdb and locate the tb_general table make sure that it is pointing to the correct version of Exchange
  2. Navigate to the tb_exchenv table. Adjust the modexch to the correct version of Exchange and adjust the correct roles that are installed on the customers' environment.
  3. Open the avapicfg.mdb and locate the tb_general table. Locate the pickupdirectorypath and replaydirectorypath columns and enter the correct pickup paths for the Exchange server. You can run the below commands from the Exchange Management Shell to obtain the correct Pickup and Replay directory paths:
    • Get-TransportServer -Identity "Server Name" | Fl name, PickupDirectoryPath
    • Get-TransportServer -Identity "Server Name" | Fl name, ReplayDirectoryPath
  4. Navigate to tb_exchenv. Select the correct version of Exchange that the customer is running and roles that are installed on the client's environment. Note: Should be similar to step 3.
  5. Replace the customer's databases with the corrected versions from the previous steps
  6. Stop the Exchange Transport service
  7. Stop all GFI services
  8. Rename the existing avapicfg.mdb to avapicfg.old and copy in the new database
  9. Rename the existing config.mdb  to config.old and copy in the new config.mdb file
  10. Start all GFI services
  11. Start the Microsoft Exchange Transport service

Confirmation 

Approved emails from quarantine should correctly be forwarded to the Exchange Pickup Folder for delivery.

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  1. Priyanka Bhotika

  2. Posted
  3. Updated

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