Overview
MailEssentials Whitelist modules allow an administrator to specify which email addresses will not be filtered for spam. Whitelisted emails are not scanned by anti-spam filters and are always delivered to the recipient.
However, there can be scenarios where emails that are in the whitelist are still filtered by a higher priority anti-spam module because MailEssentials processes the emails according to a pre-established order. This article describes the procedure to configure the priority of spam filter execution when Emails from a whitelisted sender are being classified as spam.
Diagnosis
Whitelisted emails are getting filtered as spam and not being delivered to the user's mailboxes. MailEssentials processes the emails according to the pre-established order below:
- SMTP Level Filtering (IP Blocklist, Directory Harvesting, IP DNS Block List, Greylist)
- Security and Antivirus modules
- Anti-spam modules according to their priority list
Filter Priority is configured by navigating to GFI MailEssentials Portal > Anti-Spam > Filter Priority.
Whitelisted senders will be blocked when a filtering engine that has a higher priority than the Whitelist filter is triggered by the email. In the above screenshot, the Whitelist module has priority 6 therefore any of the filters with a higher priority can still block the whitelisted email if triggered prior to the email getting processed by the Whitelist module.
Solution
Whitelisted emails can be blocked if they contain malware since the Email Security engines have a higher priority than the anti-spam filters and the Whitelist. Check that blocked emails do not violate Email Security rules.
Ensure that the anti-spam filter scanning order is set so that the Whitelist runs before other filters that are blocking the desired email. For more information refer to Sorting anti-spam filters by priority.
Confirmation
If the blocked emails do not violate security rules, they should be delivered successfully to the intended recipient.
To test the changes you can always reprocess the messages by placing the samples in EML format back into the Exchange pickup folder and check if they are allowed. Review this linked article for more information on Reprocessing Emails Wrongly Moved to the FailedMails Folder.
Priyanka Bhotika
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