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Quarantine Digest Is Not Sent

Overview

This article describes the procedure to be followed when the Quarantine digest report is not being sent to the end-users.

Diagnosis

The Quarantine digest report will not be sent in the following scenarios:

  1. When there are no emails in the Quarantine: Navigating to GFI MailEssentials > Quarantine and searching the Quarantine database shows no emails in the quarantine database.
  2. Quarantine Public URL is incorrectly configured: In this case, the log files show the following errors:
    • ..\GFI\MailEssentials\Backend\debuglogs\QuarDigest.log: 'error ","QuarDigest","ERROR: Quarantine URL is empty/null'
    • ..\GFI\MailEssentials\Antispam\DebugLogs\Subscribe@0.gfi_log.txt: 'error ","Subscribe@0","[::slave] [ERROR] Q::receive failed: 0x80004003. Exiting thread.'

This article provides a resolution to fix the above scenarios.

 

Prerequisites

Environment

  • MailEssentials should be working in IIS mode
  • All supported environments

Solution

Depending on the cause identified from the diagnosis, proceed with resolving the issue as described below:

No Emails in the Quarantine Database

When there are no emails in the Quarantine database, the quarantine digest report would not be triggered.

Usually, this will occur when the MailEssentials Spam Actions for all the filters have been set to send spam emails to an Exchange subfolder rather than the Quarantine database. Change the Spam Actions to accordingly quarantine spam and this should trigger the spam digest reports once you have emails in the Quarantine.

The Actions tab in each of the Anti-Spam filters' properties defines what should be done with emails marked as spam. This Actions should be set to "Quarantine email" for the filter to trigger the digest report as desired.

Spam_Actions.PNG

Quarantine Public URL is incorrectly configured

Quarantine digests will also not be sent out if the Quarantine URL is stripped out or incorrectly configured.

This should be fixed by following the steps below:

  1. Navivate to Start > All Programs > GFI MailEssentials > Switchboard.
  2. Confirm that the user interface mode is set to IIS mode under the UI Mode tab. Note also the IIS mode configuration URL 
    • Switchboard_UI_Mode.png
  3. Navigate to the Quarantine tab.
  4. In the 'Quarantine Public URL', enter the correct URL for your quarantine. The should be the same URL that was noted from Step 2 under the UI Mode tab.
    • Quarantine_Public_URL.png
  5. Click Apply to save the changes and accept the Services restart notification.

 

Confirmation

After applying the changes for both scenarios, the 'Quarantine Digest' should be sent out and there shouldn't be errors in the respective log files.

 

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  1. Priyanka Bhotika

  2. Posted
  3. Updated

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