Overview
MailEssentials can sometimes fail to install correctly due to a corrupt configuration database, usually named config.mdb.
This article describes the solution when the unrecognized database format issue is encountered during installation.
Diagnosis
Locate and open the installer log files using a text editor.
The installation log files are stored in the user's Temp folder and can be quickly accessed from the Run command box by typing %temp%
.
Open the main installer log named gfimes_20200701071137_010_maininstall.x64.log
and examine it for the below error message which confirms a database corruption issue:
Exception thrown by custom action:
System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation.
---> System.Data.OleDb.OleDbException: Unrecognized database format 'C:\Program Files (x86)\GFI\MailEssentials\Antispam\config.mdb'.
at System.Data.OleDb.OleDbConnectionInternal..ctor(OleDbConnectionString constr, OleDbConnection connection)
at System.Data.OleDb.OleDbConnectionFactory.CreateConnection(DbConnectionOptions options, Object poolGroupProviderInfo, DbConnectionPool pool
Solution
This issue is caused by database corruption of the MailEssentials configuration database file, config.mdb. The solution involves Compacting and Repairing the database by following the below procedure:
- Find the MailEssentials configuration database located at
..GFI\MailEssentials\Antispam\config.mdb
- Make a backup copy and open this database in Microsoft Access
- Run Compact and Repair Database utility located under the Database Tools group
- Stop all GFI MailEssentials services and rename the current config.mdb to configold.mdb.
- Replace it with the repaired config.mdb and re-run the installation
- Start all GFI MailEssentials services if not configured to start automatically.
Confirmation
The installation should complete successfully without errors in the installer log. All GFI MailEssentials services including the GFI POP2Exchange services should be Running which confirms a successful database repair and installation:
The new installer logs should be re-examined. A successful installation will have Exit code 0
as the last line in the main installer log.
Priyanka Bhotika
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